Support Email are not coming through
Resolved

We are now seeing Intercom responding - We'll close this incident, but continue to monitor

Wed, Nov 19, 2025, 06:09 PM
(2 weeks ago)
·
Affected components

No components marked as affected

Updates

Resolved

We are now seeing Intercom responding - We'll close this incident, but continue to monitor

Wed, Nov 19, 2025, 06:09 PM

Investigating

Due to an issue with our provider, our Client Support team are unable to receive emails or messages from the widget.

In the meantime, If you need to contact us you can here: https://forms.gle/GsnFDNB2bpYJhzDk9

Wed, Nov 19, 2025, 05:12 PM(56 minutes earlier)