Delay to email sending
Resolved·Degraded performance

The issue affecting email send has now be resolved and emails are being sent as normal. We will continue to monitor to ensure there are no further issues.

Tue, Nov 25, 2025, 11:33 AM
(2 weeks ago)
·
Affected components
Admin
Updates

Resolved

The issue affecting email send has now be resolved and emails are being sent as normal. We will continue to monitor to ensure there are no further issues.

Tue, Nov 25, 2025, 11:33 AM

Investigating

We are currently experiencing a slight delay to email send which we are looking into.  Emails are still being processed but may take slightly longer than normal

Tue, Nov 25, 2025, 11:24 AM